模组:模组兼容性

来自Stardew Valley Wiki
跳到导航 跳到搜索
模组使用指南 SMAPI mascot.png
2017年7月至今的SMAPI模组兼容性。参见影响该图表的重要事件

有时,在游戏发布重大更新或SMAPI自动禁用不兼容的Mod后,部分Mod会无法使用。本页面列出了已知的基于SMAPI的Mod以及它们的兼容性,并会进一步解释部分Mod无法使用的原因。



致玩家:请前往smapi.io/mods页面查阅以获得更佳体验。



对于玩家

可贡献内容

  1. 对于您安装的每个Mod,可查阅下面的表格获得这些Mod当前的兼容性状况。如果您使用的某个Mod信息不准确,可以试着更新它的相关信息。
  2. 如果您正在使用的某个依然兼容的Mod出现问题,请前往这篇帖子留言,并附上您的SMAPI日志,我们会尽可能地提供帮助。

基于SMAPI的Mod

  • 致玩家:请前往smapi.io/mods页面查阅以获得更佳体验。
  • 致Mod作者:请勇于更新下面的表格!(参考该介绍进行更新。)注意下表中尽能列出基于SMAPI的Mod,不包含XNB Mod或Content Pack。

基于SMAPI的Mod(已过时)

下表列出的Mod已经过时,或是原作者已经放弃维护,也没有任何非正式更新。即下面列出的Mod基本永远不会再有更新,也永远无法再使用。

Content packs(CP Mod)

下表列出的是基于Content Patcher等SMAPI Mod且无法使用的content pack。依然可以运行的content pack并未列出(即使它们可能会有各种不兼容的Bug出现)。

XNB Mod

参见模组:使用 XNB 模组

对于开发者

更新Mod

参见迁移指南。您可以...

  • 在前面的表格中按照特定格式添加或更新相关Mod的信息。
  • 这篇帖子内提问或告知关于您制作的Mod的信息。
  • Dicord的Mod频道参与讨论或提问题。

制作非正式Mod更新

为了避免与原作者的Mod更新产生冲突,下面给出了制作非正式Mod更新的方法。下面提供的方法假定您制作的只是基本更新(而不是续作或二创),同时Mod的源代码位于GitHub上(若源代码位于其他平台,执行下列步骤时需要进行相应修改)。

  1. 复刻仓库
  2. 在您复刻的仓库中修改相关内容(参见更新Mod)。
  3. manifest.json中的正式版本更新0.0.1的版本号并加上-unofficial.1-您的名字
    例如,如果当前Mod的版本是1.0.0,而您叫SampleUser,将版本修改为1.0.1-unofficial.1-sampleUser便可。如果您之后需要发布另一个非正式更新,将unofficial.1更新为unofficial.1即可,以此类推。这样做可以确保以后正式版本更新时可以取代非正式版更新。其他人也可以更轻松地发布非正式版更新。
  4. 将您的更改推送到GitHub。
  5. 这篇帖子中进行回复,附上您的Release Package,并留下指向您在GitHub上复刻的仓库的链接。
    (如果Mod使用了NuGet打包,那么在您的Bin文件夹中应该有名为<Mod名称> <版本号>.zip压缩包。)
  6. 如果可行的话,在原作者的仓库中创建拉取请求